Reply
Newbie
Posts: 1
Registered: ‎04-01-2011
0

Popping sounds coming from my RF-WHTIB

The rear speakers attached to my RF-WHTIB wireless rear speaker receiver sound great--most of the time. As reported by numerous reviewers on Amazon and Best Buy, I'm experiencing sporadic loud popping sounds coming from my rear speakers. Most people seem to attribute the problem to interference with wi-fi, but a few reference problems with electrical appliances. Unfortunately, no one seemed to have any solutions in their reviews. Given that this seems to be a common problem, does anyone out there have any ideas how I can fix this? Here are some specs on my home theatre/home networking setup:

 

 

Thanks for any help you can provide!

 

Rocketfish Product Specialist
Posts: 755
Registered: ‎03-22-2011
0

Re: Popping sounds coming from my RF-WHTIB

Hello Fgaliber,

 

I would suggest changing the channel that your wireless router using. If the router and the RF-WHTIB are on the same channel of the 2.4GHz spectrum then that could cause interference for both devices. On page 52 of the PDF you linked for your router is shows where you need to go to change the setting.

Regards,
Zac

Rocketfish™ Support
Visitor
Posts: 7
Registered: ‎05-16-2013
0

Re: Popping sounds coming from my RF-WHTIB

Having the same issue with poping sound.  I have 8Ohm  rear speakers, I had to buy 2 kits because I can't run wires across the room. 

 

I was wondering if having two units was causing the problem.  Ill try the Wifi fix too and update you guys if I find a fix.

 

I have a Pioneer SC65 and Def Tec 8080 Rear surrounds.

Regular Contributor
Posts: 204
Registered: ‎04-03-2013
0

Re: Popping sounds coming from my RF-WHTIB

Hello jeremy05,

 

I am sorry to hear you are having trouble with your speakers making a popping noise when connected to the RF-WHTIB.  You may also want to double check that you do not have any of the speaker wires crossed.  Make sure the negative connects to negative and positive to positive on all connections for both the sender and receiver.  Many audio receivers will have a speaker test you can run if the speakers aren't clearly labeled.  You may also try a surge protector that provides noise filtering.  If you are still having issues with the RF-WHTIB I would recommend returning with your rear speaker kit and a copy of your receipt to your place of purchase in order to pursue the possibility of warranty repair or replacement.



Regards,
Cory
Rocketfish™ Support

Visitor
Posts: 7
Registered: ‎05-16-2013
0

Re: Popping sounds coming from my RF-WHTIB

[ Edited ]

I double checked the wires and none of them are crossed.  I unpligged EVERYTHING that runs on the 2.4GHz band.  I run the full level speaker test on my Pioneer unit and everything is just fine. 

 

I have'nt tried the noise filtering surge protector, but I'm not about to buy 3 surge protectors for this as I doubt its the problem on a brand new home. 

 

Edit :  I would have to buy a surge proctector for the sending units and two more for each of the recieving units!

 

Like I said I purchased two kits and BOTH have random Popping sounds that come from the speakers.   Im going to exchange them at best buy for new ones, but from the HUGE ammount of complaints about this issue I doubt it will help. 

 

I will let everyone know how the new kits work out for me.

 

If rocketfish is denying this is a hardware issue, just Google  Rocketfish wireless Popping sound!  Every single forums has people talking about this, and nobody seems to have a solution, but to return them and hope you get a good set. 

Visitor
Posts: 7
Registered: ‎05-16-2013
0

Re: Popping sounds coming from my RF-WHTIB

So heres a Update.

 

I went to best buy and replaced BOTH RF-WHTIB with new ones, and bought $100 in Noise Canceling outlets.

 

I have the recievers and transmitters in the Noise Canceling boxes.  

 

The Wiring is Correct Positive in the Positive and Negative in the Negative

 

I have ALL 2.4GHz frequencys in the house turned off

 

The sending unit is 30feet from the Recieving unit and is in LINE OF SIGHT, so even a IR would work!

 

My Speakers are BRAND NEW DEF TEC SR8080BP

 

I have a Pioneer SC-65 AV Reciever I'm using for this.

 

I run the Audio setup and everything is correct.

 

THERE IS STILL A POPPING NOISE!!!!!!!!

 

Just admit you guys messed up in the design, or am I missing something?

 

Is there anything else I can try to get this to work or does anyone know of a Different Brand or anything else I can buy to wirelessly hook up my rear speakers!

Visitor
Posts: 7
Registered: ‎05-16-2013
0

Re: Popping sounds coming from my RF-WHTIB

Oh another fun update I forgot to mention that all FOUR boxs all have the popping sound even when the AV Reviever and TV are OFF!!!

 

Any repsonse Rocketfish????

Regular Contributor
Posts: 204
Registered: ‎04-03-2013
0

Re: Popping sounds coming from my RF-WHTIB

Hello jeremy05,

I have been unable to replicate your issue in our product lab.  There is only some limited testing we can do at this point as you have tried the most likely fixes.  With the speakers still making a popping noise when the AV Receiver is off strongly indicates that the Speaker kit is malfunctioning.  Do both wireless speaker kits you have make the noise at the same time or are they separate?  If you unplug the wireless sender units do the receivers and speakers still make the noise?  How are each of the wireless speaker kits connected?  You say that you are using two kits so I am confused about how you have them setup. 

 

I will continue to try and help you resolve this issue, but if the speakers are popping with only the rear receiver portion turned on you will need to seek warranty repair again.  If you are unhappy with the product you can ask about getting a different model or brand if you must have them warranted again.

 

Regards,
Cory
Rocketfish™ Support

Visitor
Posts: 7
Registered: ‎05-16-2013
0

Re: Popping sounds coming from my RF-WHTIB

I have two kits because I have a large great room that extends into my kitchen and dining room which  is all tile, and the location of the rear speakers are on opposite sides of the room so I can run wire from side to side either.

 

The pop is at random  from either speaker.  Never from both at the same time.  Its very random could be as long as a hour or two between the pop sound. 

 

Ill unplug the senders and let it run like that for a day or two, or until it pops obviously. 

 

I have one kit on one speaker each just using one channel.   I can not run wires from the Rear left across the kitchen to the rear right, so I had to buy two packs. 

 

 

What other models are available??  I have had good luck with all my other rocketfish products, but these have been a bust so far. 

 

I live in a rural area and driving to the nearest city costs me a good 30bucks, so I wouldn't want to exchange for pairs 5&6 to have the same result.  Would it be possible that I could get tested kits sent to me directly?

Regular Contributor
Posts: 204
Registered: ‎04-03-2013
0

Re: Popping sounds coming from my RF-WHTIB

Hello jeremy05,

I set up our RF-WHTIB in the lab with just the left channel connected and left it on my entire shift, but wasn't able to replicate the popping noise issue you are having.

 

Did you hear the popping noise with only the RF-WHTIB Receivers on and the senders unplugged?  If so we have isolated the issue to the receiving portion of the kit.  Since you are using noise filtering surge protectors we can rule out electrical.  We have confirmed the speakers are compatible in there Ohm rating.  There could still be some sort of wireless interference, but is unlikely as well since you eliminated all the other 2.4GHz systems before.  You could try only using one kit temporarily to see if they are interfering with each other and causing the issue.

 

If you haven't heard the popping noise with the sender unplugged you can further test by plugging the sender back into power, but having no speaker wire plugged into them.  If the popping noise occurs this way you could try only using one kit temporarily to see if they are interfering with each other and causing the issue.  If the popping noise still doesn't occur it would seem that the stereo is sending a signal that is causing it whether it is on or off.

 

 

Sometimes when running into a dead end on troubleshooting I find it helps to start over completely.

 

  • Start by completely disconnecting the power cables from the stereo receiver and all 4 pieces of the RF-WHTIB.
  • Then remove each speaker wire connection from the stereo and the RF-WHTIBs.
  • With everything completely disconnected you will want to reattach everything methodically.
  • Connect one side of the system entirely before connecting the other making sure the sender and receiver are pairing to each other before connecting the other side.  The sender and receiver should be paired from the factory and not pair to the other set you have.
  • Double check that all wires on the correct spot and bare wires are crossed or touching.
  • You want to set the audio receivers output to a level that allows you to leave the RF-WHTIB at half volume if possible.


Regards,
Cory
Rocketfish™ Support