Reply
Newbie
Posts: 1
Registered: ‎09-01-2011
0

Rocketfish RF-WHTIB Not Working

Hi,

 

I just purchased the Rocketfish RF-WHTIB but I am unable to get it to work. Here are the details:

 

- Both devices are connected properly

- When I power on the sender it the red light flashes until I connect turn on the receiver

- After turning on the receiver the sender goes solid for 1 second then the light turns off

- I have tried manually issuing a connect by pressing the connect button on both the receiver and sender but with no success.

 

I am unable to get the sender's light to stay on solid.

 

Please help,

Jonathan

Rocketfish Product Specialist
Posts: 755
Registered: ‎03-22-2011
0

Re: Rocketfish RF-WHTIB Not Working

Hello Laoabal,

 

If the light is turning off that means that the unit is shutting itself off. Under normal operating conditions the units will blink until they pair with each other and should not shut themselves off. Since this is the case, I would suggest plugging the device into a different power outlet to see if the result is the same. If the unit continues to turn itself off, I would suggest taking them along with the receipt to the place of purchase to obtain warranty service. The RF-WHTIB has a 1 year warranty from the date of purchase.

Regards,
Zac

Rocketfish™ Support
Newbie
Posts: 1
Registered: ‎04-27-2016
0

Re: Rocketfish RF-WHTIB Not Working

This is similar to the problem I'm having. When we try to turn the receiver on, the light comes on briefly, blinks in some pattern, then shuts off. (I've seen a reply elsewhere that suggests that the pattern of blinks is meaningless.)

Ours is a few years old. Should I assume that these units only have a lifetime of a few years? If so, do you have a more reliable model?

Highlighted
Rocketfish Support
Posts: 74
Registered: ‎08-27-2015
0

Re: Rocketfish RF-WHTIB Not Working

Hello TheOtherJim,

Welcome to Community@ Rocketfish™!

Unplug the unit for at least a minute. When you plug it back in, try it in a different outlet.Does this change the issue at all? With your model, does the power cable for the receiver plug in or is it hard wired into the unit? If it plugs in, unplug it and make sure it gets properly seated. 

Regards,
Ryan
Rocketfish™ Support