Reply
Newbie
Posts: 2
Registered: ‎01-05-2015
0

MHL adapter not working with my Samsung Galaxy S3 connection to my "60 Vizio smart tv

I hooked up everything as instructed in the quick setup guide. The only thing different is I dont have the samsung optional adapter hooked into my S3 because when I hook that up into my phone I get no connection. I know this because when I hook it up with out the optional adapter it shows its charging, but when I hook up the optional adapter there's no charge. Anyways even though I see a charge im getting a no signal black page on my tv. I went to my settings on my tv and enabled the CEC function and it still shows no signal, even though on my input menu its shows that it acknowledges an MHL device. In my CEC settings I click on device discovery and it shows an MHL Device. So my tv acknowledges it. Maybe its my phone? Idk I even went out and bought a new and better HDMI cord. Should I buy a new charger. I dont think
thats the problem since it gives me a charge through the MHL device. I read the other post on here in tried the hdmi reset, where I unplug everything and turn off my phone and tv, but even that didn't work. Plzz help thx
Rocketfish Support
Posts: 157
Registered: ‎07-21-2014
0

Re: MHL adapter not working with my Samsung Galaxy S3 connection to my "60 Vizio smart tv

Hello xrickeegx,

Welcome to Community@ Rocketfish™!

If the TV is seeing a MHL device connected, the adapter is working and supplying power. At this point you need to enable the display output on the phone. It may be a service called Screen Mirroring.

Regards,
Jon
Rocketfish™ Support

Newbie
Posts: 2
Registered: ‎01-05-2015
0

Re: MHL adapter not working with my Samsung Galaxy S3 connection to my "60 Vizio smart tv

It scans for available devices but no devices found. Any other solutions?
Highlighted
Rocketfish Support
Posts: 157
Registered: ‎07-21-2014
0

Re: MHL adapter not working with my Samsung Galaxy S3 connection to my "60 Vizio smart tv

Hello xrickeegx,

Thank you for responding!

If the option you are selecting is "scanning for devices" it sounds like its looking for a wireless option over wifi or something. At this point I would refer you to Samsung to find out how to activate video output over MHL. I know with my S4, it automatically detects the connection and shows on the screen, but the S3 sounds like it needs a app or setting to be manually activated.

Regards,
Jon
Rocketfish™ Support